LM 19.2 nejde zvuk Audigy 2

Problémy a zkušenosti s hardwarem, perifériemi a ovladači
Zpráva
Autor
menom
Guru Mintu
Příspěvky: 1606
Registrován: 12 pro 2012, 15:10

Re: LM 19.2 nejde zvuk Audigy 2

#11 Příspěvek od menom » 08 srp 2019, 06:57

.

Nj, ja ked pustim nieco vo VLC, tak mi vypise State: RUNNING

Co to PCM, jde to zvolit - oznacit ?

.

Uživatelský avatar
labeent
Příspěvky: 74
Registrován: 14 lis 2012, 22:57

Re: LM 19.2 nejde zvuk Audigy 2

#12 Příspěvek od labeent » 08 srp 2019, 08:39

Teď u toho nejsem, ale podle obrázku je to zaškrtnuté a inverzní, čili to volit nejde ale mělo by to být zaplé ...
Obrázek

Uživatelský avatar
labeent
Příspěvky: 74
Registrován: 14 lis 2012, 22:57

Re: LM 19.2 nejde zvuk Audigy 2

#13 Příspěvek od labeent » 08 srp 2019, 20:19

labeent píše:
08 srp 2019, 08:39
Teď u toho nejsem, ale podle obrázku je to zaškrtnuté a inverzní, čili to volit nejde ale mělo by to být zaplé ...
JJ, je to tak ...
Obrázek

menom
Guru Mintu
Příspěvky: 1606
Registrován: 12 pro 2012, 15:10

Re: LM 19.2 nejde zvuk Audigy 2

#14 Příspěvek od menom » 08 srp 2019, 21:02

.

Vypada to, ze nastavene to je dobre, ale to nejede.
Na tvojom mieste by som zadal do terminalu prikaz ked vlc prehrava, kde je pulse audio dopodrobna rozpisane:

Kód: Vybrat vše

pacmd list cards
Ak to fungovalo v Live OS beta 19.2, tam urobit rovnaky vypis za rovnakych podmienok a porovnat co je jinak.

.

Uživatelský avatar
redhawk
Guru Mintu
Příspěvky: 3032
Registrován: 12 led 2016, 19:14
Bydliště: ako kedy

Re: LM 19.2 nejde zvuk Audigy 2

#15 Příspěvek od redhawk » 08 srp 2019, 21:10

spravit

Kód: Vybrat vše

pulseaudio -k
sudo service alsa-utils stop
sudo modprobe -r snd_emu10k1
sudo modprobe snd_emu10k1
sudo service alsa-utils start
pulseaudio -D
EDIT:
ak to nezaberie este by som skusil lts kernel 4.19 mam audigy 1 a ta mala s LM problem uz v 18.3
v ubuntu mi blbla s kernelom vyssim nez 4.19.
manjaro som musel manualne instalovat snd_emu10k1 driver

e este jedna vec live 19.2 ma aky kernel?
Pravděpodobně kecám.
Hlúposť užívateľa je úmerná jeho právam.
Podstatou pirátstva nie je túžba ľudí kradnúť, ale neschopnosť predať im veci, ktoré chcú.

Uživatelský avatar
labeent
Příspěvky: 74
Registrován: 14 lis 2012, 22:57

Re: LM 19.2 nejde zvuk Audigy 2

#16 Příspěvek od labeent » 08 srp 2019, 22:11

redhawk píše:
08 srp 2019, 21:10
spravit

Kód: Vybrat vše

pulseaudio -k
sudo service alsa-utils stop
sudo modprobe -r snd_emu10k1
sudo modprobe snd_emu10k1
sudo service alsa-utils start
pulseaudio -D
EDIT:
ak to nezaberie este by som skusil lts kernel 4.19 mam audigy 1 a ta mala s LM problem uz v 18.3
v ubuntu mi blbla s kernelom vyssim nez 4.19.
manjaro som musel manualne instalovat snd_emu10k1 driver

e este jedna vec live 19.2 ma aky kernel?
Takže při zadání příkazů se stalo toto:

Kód: Vybrat vše

Terminal:~$ pulseaudio -k
Terminal:~$ sudo service alsa-utils stop
[sudo] heslo pro ***:       
Terminal:~$ sudo modprobe -r snd_emu10k1
modprobe: FATAL: Module snd_emu10k1 is in use.
Terminal:~$ sudo modprobe snd_emu10k1
Terminal:~$ sudo service alsa-utils start
Failed to start alsa-utils.service: Unit alsa-utils.service is masked.
Terminal:~$ pulseaudio -D
E: [pulseaudio] main.c: Spuštění démona selhalo.
Obrázek

Uživatelský avatar
redhawk
Guru Mintu
Příspěvky: 3032
Registrován: 12 led 2016, 19:14
Bydliště: ako kedy

Re: LM 19.2 nejde zvuk Audigy 2

#17 Příspěvek od redhawk » 08 srp 2019, 23:51

labeent píše:
08 srp 2019, 22:11


Takže při zadání příkazů se stalo toto:

Kód: Vybrat vše

Terminal:~$ pulseaudio -k
Terminal:~$ sudo service alsa-utils stop
[sudo] heslo pro ***:       
Terminal:~$ sudo modprobe -r snd_emu10k1
modprobe: FATAL: Module snd_emu10k1 is in use.
Terminal:~$ sudo modprobe snd_emu10k1
Terminal:~$ sudo service alsa-utils start
Failed to start alsa-utils.service: Unit alsa-utils.service is masked.
Terminal:~$ pulseaudio -D
E: [pulseaudio] main.c: Spuštění démona selhalo.
nieco blokuje modul, to moze byt aj dovod nefunkcnosti
prvy krok zistit co

Kód: Vybrat vše

lsmod | grep snd_emu10k1
bude vypis co to drzi.
pokracovat:

Kód: Vybrat vše

pulseaudio -k
sudo service alsa-utils stop
druhy krok

Kód: Vybrat vše

sudo modprobe -r <module ktory vypise lsmod> snd_emu10k1
a dalej:

Kód: Vybrat vše

sudo modprobe snd_emu10k1
service alsa-utils start
pulseaudio -D
Pravděpodobně kecám.
Hlúposť užívateľa je úmerná jeho právam.
Podstatou pirátstva nie je túžba ľudí kradnúť, ale neschopnosť predať im veci, ktoré chcú.

Uživatelský avatar
labeent
Příspěvky: 74
Registrován: 14 lis 2012, 22:57

Re: LM 19.2 nejde zvuk Audigy 2

#18 Příspěvek od labeent » 09 srp 2019, 13:44

Ahoj,
tak po zadání příkazů to napsalo tohle:

Kód: Vybrat vše

Terminal:~$ lsmod | grep snd_emu10k1
snd_emu10k1_synth      24576  0
snd_emux_synth         40960  1 snd_emu10k1_synth
snd_emu10k1           159744  3 snd_emu10k1_synth
snd_util_mem           16384  2 snd_emu10k1,snd_emux_synth
snd_ac97_codec        135168  1 snd_emu10k1
snd_hwdep              20480  3 snd_hda_codec,snd_emu10k1,snd_emux_synth
snd_pcm               102400  6 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_emu10k1,snd_ac97_codec,snd_hda_core
snd_rawmidi            36864  3 snd_seq_midi,snd_emu10k1,snd_seq_virmidi
snd_seq_device         16384  5 snd_seq,snd_seq_midi,snd_emu10k1,snd_emu10k1_synth,snd_rawmidi
snd_timer              36864  3 snd_seq,snd_emu10k1,snd_pcm
snd                    86016  21 snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_emu10k1,snd_timer,snd_ac97_codec,snd_seq_virmidi,snd_emux_synth,snd_pcm,snd_rawmidi
Co mám tedy doplnit do příkazu

Kód: Vybrat vše

sudo modprobe -r <module ktory vypise lsmod> snd_emu10k1
?

Díky
Obrázek

Uživatelský avatar
redhawk
Guru Mintu
Příspěvky: 3032
Registrován: 12 led 2016, 19:14
Bydliště: ako kedy

Re: LM 19.2 nejde zvuk Audigy 2

#19 Příspěvek od redhawk » 09 srp 2019, 15:47

labeent píše:
09 srp 2019, 13:44
Ahoj,
tak po zadání příkazů to napsalo tohle:

Kód: Vybrat vše

Terminal:~$ lsmod | grep snd_emu10k1
snd_emu10k1_synth      24576  0
snd_emux_synth         40960  1 snd_emu10k1_synth
snd_emu10k1           159744  3 snd_emu10k1_synth
snd_util_mem           16384  2 snd_emu10k1,snd_emux_synth
snd_ac97_codec        135168  1 snd_emu10k1
snd_hwdep              20480  3 snd_hda_codec,snd_emu10k1,snd_emux_synth
snd_pcm               102400  6 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_emu10k1,snd_ac97_codec,snd_hda_core
snd_rawmidi            36864  3 snd_seq_midi,snd_emu10k1,snd_seq_virmidi
snd_seq_device         16384  5 snd_seq,snd_seq_midi,snd_emu10k1,snd_emu10k1_synth,snd_rawmidi
snd_timer              36864  3 snd_seq,snd_emu10k1,snd_pcm
snd                    86016  21 snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_emu10k1,snd_timer,snd_ac97_codec,snd_seq_virmidi,snd_emux_synth,snd_pcm,snd_rawmidi
Co mám tedy doplnit do příkazu

Kód: Vybrat vše

sudo modprobe -r <module ktory vypise lsmod> snd_emu10k1
?

Díky

Kód: Vybrat vše

sudo modprobe -r snd_util_mem  snd_emu10k1
sudo modprobe -r snd_ac97_codec snd_emu10k1
sudo modprobe -r snd_hwdep   snd_emu10k1
sudo modprobe -r snd_pcm snd_emu10k1
sudo modprobe -r snd_rawmidi snd_emu10k1
sudo modprobe -r snd_seq_device snd_emu10k1
sudo modprobe -r snd_timer  snd_emu10k1
sudo modprobe -r snd  snd_emu10k1
nasledne dokoncit

Kód: Vybrat vše

sudo modprobe snd_emu10k1
sudo service alsa-utils start
pulseaudio -D
pfu tak toto vidim prvy krat, Ubuntu to vacsinou blokuje rawmidi.
a
Pravděpodobně kecám.
Hlúposť užívateľa je úmerná jeho právam.
Podstatou pirátstva nie je túžba ľudí kradnúť, ale neschopnosť predať im veci, ktoré chcú.

Uživatelský avatar
labeent
Příspěvky: 74
Registrován: 14 lis 2012, 22:57

Re: LM 19.2 nejde zvuk Audigy 2

#20 Příspěvek od labeent » 09 srp 2019, 16:34

Je to prostě nějaké zakleté:

Kód: Vybrat vše

Terminal:~$ sudo modprobe -r snd_util_mem  snd_emu10k1
[sudo] heslo pro ****:       
modprobe: FATAL: Module snd_util_mem is in use.
Terminal:~$ sudo modprobe -r snd_ac97_codec snd_emu10k1
modprobe: FATAL: Module snd_ac97_codec is in use.
Terminal:~$ sudo modprobe -r snd_hwdep   snd_emu10k1
modprobe: FATAL: Module snd_hwdep is in use.
Terminal:~$ sudo modprobe -r snd_pcm snd_emu10k1
modprobe: FATAL: Module snd_pcm is in use.
Terminal:~$ sudo modprobe -r snd_rawmidi snd_emu10k1
modprobe: FATAL: Module snd_rawmidi is in use.
Terminal:~$ sudo modprobe -r snd_seq_device snd_emu10k1
modprobe: FATAL: Module snd_seq_device is in use.
Terminal:~$ sudo modprobe -r snd_timer  snd_emu10k1
modprobe: FATAL: Module snd_timer is in use.
Terminal:~$ sudo modprobe -r snd  snd_emu10k1
modprobe: FATAL: Module snd is in use.
Terminal:~$ sudo modprobe snd_emu10k1
Terminal:~$ sudo service alsa-utils start
Failed to start alsa-utils.service: Unit alsa-utils.service is masked.
Terminal:~$ pulseaudio -D
E: [pulseaudio] main.c: Spuštění démona selhalo.
Terminal:~$ 
Obrázek

Odpovědět