Trhane video v LM20/19/18

Prohlížení, zpracování, editace a tvorba multimediálních souborů (hudba, video, obrázky, ...)
Zpráva
Autor
gusto1
Příspěvky: 81
Registrován: 07 pro 2017, 08:46

Trhane video v LM20/19/18

#1 Příspěvek od gusto1 » 05 říj 2020, 10:21

Do nedavna som pouzival LM17 a nemal som problem s prehravanim videa (VLC, KODI ...). Mal/mam stary PC (asi 10 rocny) je tam nejaky serverovy CPU xeon 5460, 8 GB ram a nejaka lacna invidia grafika (presne parametre neviem lebo som mimo PC).
Fakt som bol s touto zostavou a ML17 nad mieru spokojny.
Ked skoncila podpora LM17, tak som chcel prejst na LM18, ale video sa uz neprehravalo plynule (obraz bol trhany a pri posuvani kamery (napr. pri sportovych prenosoch to bolo hodne vidno)).
Skusal som rozne nastavenia v KODI, ale obraz bol vzdy trhany (nebol plynuly). Pri beznom filme som to nezbadal, ale napr. pri hokeji katastrofa. Vratil som sa znova na LM17 kde bol a este stale je obraz super. Potom prisiel LM19, tak som si myslel, ze to bude lepsie, ale nic sa nezmenilo. Teraz som presiel na LM20 a je to o tom istom.
Kedze moj PC ma uz viac ako 10 rokov a uz don nechcem investovat, tak som si povedal, to bude zrejme stara GPU a uz nema podporu v kernely, tak si kupim/poskladam novi PC.

Kód: Vybrat vše

system:    Kernel: 5.4.0-48-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.6.7 
           Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal 
Machine:   Type: Desktop Mobo: ASRock model: H310CM-ITX/ac serial: <filter> UEFI: American Megatrends v: P4.10 
           date: 05/14/2019 
CPU:       Topology: Dual Core model: Intel Pentium Gold G5400 bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 4096 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 29598 
           Speed: 800 MHz min/max: 800/3700 MHz Core speeds (MHz): 1: 800 2: 800 3: 801 4: 801 
Graphics:  Device-1: Intel vendor: ASRock driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa resolution: 2560x1440~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 610 (CFL GT1) v: 4.6 Mesa 20.0.8 direct render: Yes 
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: ASRock driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.4.0-48-generic 
Network:   Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:1f.6 
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel port: f040 bus ID: 02:00.0 
           IF: wlp2s0 state: down mac: <filter> 
Drives:    Local Storage: total: 261.76 GiB used: 27.67 GiB (10.6%) 
           ID-1: /dev/nvme0n1 vendor: Kingston model: SA2000M8250G size: 232.89 GiB 
           ID-2: /dev/sda type: USB vendor: Kingston model: DataTraveler 3.0 size: 28.88 GiB 
Partition: ID-1: / size: 151.33 GiB used: 9.47 GiB (6.3%) fs: ext4 dev: /dev/nvme0n1p5 
Sensors:   System Temperatures: cpu: 33.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 220 Uptime: 36m Memory: 7.46 GiB used: 1.25 GiB (16.8%) Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 
           Shell: bash v: 5.0.17 inxi: 3.0.38 
Tak na tom to musi slapat super. Opak je pravdou, video je take iste (trhane), takze problem asi nebol v HW a ja som mohol ostat pri mojom starom dobrom PC. Este spomeniem, ze video streamujem z DVB-S2 boxu (to je ale jedno ci streamujem z boxu, netu, alebo prehravam z HDD).
Skusal som vselico od distier zalozenych na debiane LM, LMDE, MX, Debian, vsade bol ten problem.
Nakoniec som skusil Win 10 a po instalacii som tam hodil len KODI + PVR a ono to slape krasne, bez trhania. Nechcem vsak pouzivat WIN.
Nemam tolko casu, aby som testoval dalsie distra ako napr. fedora, opensuse atd ... Som zvyknuty na LM, ale rad by som zistil, ze v com je problem.
Nasiel som strasne vela diskusii ohladom trhaneho videa od ver. LM18 a nikde som nenasiel riesenie (aj ked niekde bolo uvedene, ze ked som zmenil to, alebo ono, tak obraz uz nie je trhany, ale mne nepomohlo nic z toho).
Napr. https://forums.linuxmint.com/viewtopic. ... 8&t=227664 a takychto diskusii je mnoho.

Ako som spomenul, pri obycajnych filmoch, spravach, beznych scenach to nie je vidiet, ale pri hokeji, futbale a pod. ked sa pohybuje kamera, tak je to velmi neprijemne na oci. Niekto si mozno na to zvykne, ked to nema s cim porovnat, ale mna z toho bolia oci

Uživatelský avatar
Ventero1
Guru Mintu
Příspěvky: 1531
Registrován: 31 říj 2016, 14:17
Bydliště: Sokolov

Re: Trhane video v LM20/19/18

#2 Příspěvek od Ventero1 » 05 říj 2020, 12:39

A nepopisujes nahodou jev zvany "tearing"? Zkus pohledat toto - i zde na foru je k tomu nekolik vlaken.
Zvuky jsou mantrami a myšlenky moudrostí, prostě proto, že se mohou objevovat ...

Uživatelský avatar
amenhotep
Příspěvky: 21
Registrován: 22 čer 2014, 10:17

Re: Trhane video v LM20/19/18

#3 Příspěvek od amenhotep » 05 říj 2020, 15:23

Zkus v OpenGL vypnout položku Allow Flipping
Přílohy
opengl-41_2020-10-05-15-29-43.jpeg

gusto1
Příspěvky: 81
Registrován: 07 pro 2017, 08:46

Re: Trhane video v LM20/19/18

#4 Příspěvek od gusto1 » 05 říj 2020, 16:48

Neviem ako sa to správne naziva, ale skôr by som povedal ze choppy. Mam Intel grafiku, takže v opengl by som asi nič nenastavil. Vám videa fungujú ok?

juhele2014
Guru Mintu
Příspěvky: 2364
Registrován: 19 kvě 2014, 17:47

Re: Trhane video v LM20/19/18

#5 Příspěvek od juhele2014 » 05 říj 2020, 16:56

Jako to jo, ale nikde Nvidii v tom výpisu nevidím. Ale obecně - cinnamon je pro silný stroje, tady bych začal, kor když to chce na audio-video. Takže něco jinýho, mate nebo xfce. Ta 20ka taky není ještě odladěná, takže doporučuju LM 19.3, nebo LM 19.2. CPU mám podobný (Dual Core model: Intel Pentium G4400 bits: 64 type), ale video jedu max. full HD, takže 1920x1090. Ale gusto1 používá vyšší rozlišení, takže to bude chtít (asi) graf. kartu. Teda jestli to správně chápu ... Jo, a co se týká kernelu - instalovat něco hodně novýho, řadu 5.xx, to taky docela pomůže. A jestli nejede na max. rozlišení monitoru, tak snížit rozlišení ... To ale asi ví ...
ps : Doufám, že tu desku nemá z Alzy ... :(

gusto1
Příspěvky: 81
Registrován: 07 pro 2017, 08:46

Re: Trhane video v LM20/19/18

#6 Příspěvek od gusto1 » 05 říj 2020, 18:43

skúšal som keď vyšli aj 18, 19 a teraz 20. Možno som neskúšal všetky 18.x, 19.x ale obraz bol trhany všade. Dokonca aj 17.3 myslím nebola ok. Ideálne to išlo na LM17.
Ako prvé vždy inštaluje xfce, a myslím si, že g5400 a 8gb ram nemôže robiť problém. MB som nekupoval v alze, ale to je asi jedno. Vo win 10 to ide ako víno, takže HW bude OK. Není problém testovať rôzne ver. ale stratím pri tom veľa času a výsledok sa nemusí dostaviť.

juhele2014
Guru Mintu
Příspěvky: 2364
Registrován: 19 kvě 2014, 17:47

Re: Trhane video v LM20/19/18

#7 Příspěvek od juhele2014 » 05 říj 2020, 18:56

https://www.youtube.com/watch?v=3E9dTm4SCiA

Není to tento problém? Pro ilustraci - v Chromiu 85, LM 19.2 xfce, kernel 5.6.11, a s procákem G4400 mě to zatíží asi na 60% výkonu, rozlišení sem si dal maximální, tedy 1080HD. Ještě dotaz - co máš za monitor, a jaký rozlišení, napiš i zatížení cpu při přehrávání. jestli je to jenom cukání při přehrávání, tak ti možná chybí nějaký kodeky, ale to jen fabuluju ...

S přehráváním videa na této mašině:

Kód: Vybrat vše

rudla@rudla-pc:~$ inxi -F
System:
  Host: rudla-pc Kernel: 5.6.11-050611-generic x86_64 bits: 64 
  Desktop: Xfce 4.12.3 Distro: Linux Mint 19.2 Tina 
Machine:
  Type: Desktop System: Gigabyte product: H110M-S2 v: N/A 
  serial: <root required> 
  Mobo: Gigabyte model: H110M-S2-CF v: x.x serial: <root required> 
  UEFI [Legacy]: American Megatrends v: F21 date: 06/09/2017 
CPU:
  Topology: Dual Core model: Intel Pentium G4400 bits: 64 type: MCP 
  L2 cache: 3072 KiB 
  Speed: 800 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 800 2: 800 
Graphics:
  Device-1: Intel HD Graphics 510 driver: i915 v: kernel 
  Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 510 (SKL GT1) 
  v: 4.6 Mesa 20.0.8 
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio 
  driver: snd_hda_intel 
  Sound Server: ALSA v: k5.6.11-050611-generic 
není absolutně žádný problém ...

menom
Guru Mintu
Příspěvky: 1956
Registrován: 12 pro 2012, 15:10

Re: Trhane video v LM20/19/18

#8 Příspěvek od menom » 05 říj 2020, 19:02

.

Je tam ovladac modesetting, mozno ho vymenit za intel.

Na tvojom mieste by som pre intel vyskusal toto:
Vytvorit adresar xorg.conf.d v /etc/X11/

Kód: Vybrat vše

sudo mkdir -p /etc/X11/xorg.conf.d

Druhy prikaz po kopirovani do terminalu a zadani hesla vytvori subor 20-intel.conf
v adresari /etc/X11/xorg.conf.d/
s obsahom

Kód: Vybrat vše

sudo tee /etc/X11/xorg.conf.d/20-intel.conf <<END
Section "Device"
   Identifier "Intel Graphics"
   Driver "intel"
   Option "TearFree" "true"
EndSection
END
Reboot

.

juhele2014
Guru Mintu
Příspěvky: 2364
Registrován: 19 kvě 2014, 17:47

Re: Trhane video v LM20/19/18

#9 Příspěvek od juhele2014 » 05 říj 2020, 19:13

:arrow: menom
Je to přesně, jak píšeš, mám to tam:

Kód: Vybrat vše

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
  Option "TearFree" "true"
EndSection
No jo, no. My, co sme tady už dlouho, tak některý finesy aplikujeme, tak nějak letmo, a pak to vypadá, že nám všechno funguje ... Někdy ... :D

menom
Guru Mintu
Příspěvky: 1956
Registrován: 12 pro 2012, 15:10

Re: Trhane video v LM20/19/18

#10 Příspěvek od menom » 05 říj 2020, 19:29

.

:D

Ano pisal mu to Ventero, len najst a vyskusat, pred nakym casom som objavil

tento pekny prikaz do terminalu.

A ze v novsich LM uz neni adresar xorg.conf.d v /etc/X11/ to je detail.

To sa da napravit ....

.

Odpovědět