Google Drive

Diskuze, problémy a zkušenosti s programy, nástroji nebo balíčkovacími systémy
Zpráva
Autor
Abby
Poradce Mintu
Příspěvky: 291
Registrován: 11 led 2016, 16:59

Google Drive

#1 Příspěvek od Abby » 29 lis 2018, 13:48

Potřebovala bych poradit funkčního klienta pro Google Drive. Teď mám nainstalovaný Grive Tools, ale ten spíše nefunguje než ano, na synchronizaci se nedá spolehnout a právě jsem zjistila, že poslední synchronizace mi proběhla 24.11.18 i přesto, že jsem přidávala, ubírala a měnila soubory na různých místech včetně Linuxu. Takže se obávám co tam budu mít za bordel a co mi bude chybět.

Poradíte mi funkčního klienta, který automaticky synchronizuje změny a prostě funguje jako originál pro Windows? Může být klidně i jen pro terminál, hlavně aby fungoval, spouštěl se automaticky a dělal to co má (a k němu prosím návod :-) ). Děkuji.

edit: jedná se o distribuci Antergos
Naposledy upravil(a) Abby dne 30 lis 2018, 13:21, celkem upraveno 1 x.

Abby
Poradce Mintu
Příspěvky: 291
Registrován: 11 led 2016, 16:59

Re: Google Drive

#2 Příspěvek od Abby » 29 lis 2018, 16:40

Díky, jak to funguje? Je to klasická synchronizace?

Abby
Poradce Mintu
Příspěvky: 291
Registrován: 11 led 2016, 16:59

Re: Google Drive

#3 Příspěvek od Abby » 29 lis 2018, 20:05

Tak se mi to nepovedlo nainstalovat, hlásí to nějakou chybu...

Abby
Poradce Mintu
Příspěvky: 291
Registrován: 11 led 2016, 16:59

Re: Google Drive

#4 Příspěvek od Abby » 30 lis 2018, 00:33

Žádný Linux Mint, jde o Antergos, ale tady je snad jediné funkční linuxové české fórum, proto se ptám tady, snad to nevadí. Jestli to dobře chápu tak to tvrdí, že balíček potřebuje starší ocamlfuse než je nainstalovaný, přikládám screenshot.

Obrázek

Existuje něco dalšího? Klidně si zaplatím za licenci (jednorázově, ne formou předplatného), hlavně ať to funguje.

Livan
Příspěvky: 134
Registrován: 16 kvě 2014, 21:15

Re: Google Drive

#5 Příspěvek od Livan » 30 lis 2018, 12:40

V antergose sú dve možnosti, ako toto nainštalovať. Prvá je priamo z gitu, pokiaľ máš nainštalovaný program git. Postupne spustiť nasledovné tri príkazy:

Kód: Vybrat vše

git clone https://aur.archlinux.org/google-drive-ocamlfuse.git 
cd google-drive-ocamlfuse
makepkg -sri
druhá možnosť, je zapnúť v pamac alebo octopi, podľa toho čo používaš, podporu AUR a tam ten program vyhľadať a nainštalovať. Alebo pomocou programu napr. yaourt, ktorý musíš mať predtým nainaštalovaný. Slúži na inštaláciu programov z AUR pomocou terminálu.

Kód: Vybrat vše

yaourt -S google-drive-ocamlfuse
Naposledy upravil(a) Livan dne 30 lis 2018, 13:22, celkem upraveno 1 x.

Abby
Poradce Mintu
Příspěvky: 291
Registrován: 11 led 2016, 16:59

Re: Google Drive

#6 Příspěvek od Abby » 30 lis 2018, 13:21

Livan: git nainstalovaný nemám, obávám se že nevím jak s ním zacházet... Jak se případně program z git odinstaluje? AUR mám aktivní ale tam to právě hlásí tu chybu.

redhawk: asi by to chtělo, jenže fórum antergos je totálně mrtvé a celkově je to takové že jediné kde to funguje je tady. Příště to napíšu.

Livan
Příspěvky: 134
Registrován: 16 kvě 2014, 21:15

Re: Google Drive

#7 Příspěvek od Livan » 30 lis 2018, 13:28

Abby píše:
30 lis 2018, 13:21
Livan: git nainstalovaný nemám, obávám se že nevím jak s ním zacházet... Jak se případně program z git odinstaluje? AUR mám aktivní ale tam to právě hlásí tu chybu.

redhawk: asi by to chtělo, jenže fórum antergos je totálně mrtvé a celkově je to takové že jediné kde to funguje je tady. Příště to napíšu.
tak si skús ten git pomocou pamac či octopi nainštalovať. Potom stačí postupne skopírovať do terminálu tie tri príkazy a nechať ich vykonať. Prvým sa skopíruje obsah gitu na tvoj PC. Druhým sa presunieš do daného adresára a tretím ten program skompiluješ a nainštaluješ. Máš tam 3 možnosti, jedna z nich bude určite fungovať.
P. S. ak nevieš ako tie príkazy použiť - označ ich myšou, zapni terminál a kolieskom klikni do terminálu na pozíciu kurzoru. Tak sa ten príkaz skopíruje. Potom stačí už iba stlačiť Enter. Príkazy kopíruj po riadkoch a vždy nechaj vykonať a až potom pokračuj.

Abby
Poradce Mintu
Příspěvky: 291
Registrován: 11 led 2016, 16:59

Re: Google Drive

#8 Příspěvek od Abby » 30 lis 2018, 14:36

Livan: s terminálem zacházet umím a zkopírovat příkazy také, tak hloupá snad ještě nejsem :-) Já se totiž stále učím a přiznám se že preferuju GUI a klikátka (a to co je potřeba udělat v konsoli mám hezky napsané v poznámkách krok za krokem a v případě potřeby to zkopíruju, nepamatuju si ty příkazy, jen pár základních). Jinak tedy rozhodně děkuji za návod. Jen se zeptám, v pamac (Přidat/odebrat software?) mám i google-drive-ocamlfuse-git, nestačilo by třeba nainstalovat tohle? Nebo se to musí přes ten příkaz v konsoli? A jak se to případně odinstaluje když by to nefungovalo?

edit: git mám nainstalovaný (už byl) tak to jdu zkusit :-)

Abby
Poradce Mintu
Příspěvky: 291
Registrován: 11 led 2016, 16:59

Re: Google Drive

#9 Příspěvek od Abby » 30 lis 2018, 14:51

Tak je tu stejný problém jako při instalaci v GUI:

Kód: Vybrat vše

[abby@Daemon-Antergos google-drive-ocamlfuse]$ makepkg -sri
==> Vytváří se balíček: google-drive-ocamlfuse 0.7.0-1 (Pá 30. listopadu 2018, 14:48:19 CET)
==> Kontrola runtime závislostí...
==> Kontrola buildtime závislostí...
==> Získávají se zdrojové soubory...
  -> Stahuje se v0.7.0.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   138    0   138    0     0    185      0 --:--:-- --:--:-- --:--:--   185
100 76696    0 76696    0     0  46174      0 --:--:--  0:00:01 --:--:--   98k
==> Kontrola source souborů pomocí sha256sums...
    v0.7.0.tar.gz ... Prošel
==> Rozbalují se zdrojové soubory...
  -> Rozbaluje se v0.7.0.tar.gz pomocí bsdtar
==> Spouští se build()...
    ocamlopt src/.google_drive_ocamlfuse.objs/dbCache.{cmx,o} (exit 2)
(cd _build/default && /usr/bin/ocamlopt.opt -w -40 -w -3-27-32-58 -g -I src/.google_drive_ocamlfuse.objs -I src/.google_drive_ocamlfuse.objs/.private -I /usr/lib/ocaml/Fuse -I /usr/lib/ocaml/biniou -I /usr/lib/ocaml/bytes -I /usr/lib/ocaml/cryptokit -I /usr/lib/ocaml/curl -I /usr/lib/ocaml/easy-format -I /usr/lib/ocaml/extlib -I /usr/lib/ocaml/gapi-ocaml -I /usr/lib/ocaml/netstring -I /usr/lib/ocaml/netsys -I /usr/lib/ocaml/sqlite3 -I /usr/lib/ocaml/threads -I /usr/lib/ocaml/yojson -I /usr/lib/ocaml/zarith -intf-suffix .ml -no-alias-deps -o src/.google_drive_ocamlfuse.objs/dbCache.cmx -c -impl src/dbCache.ml)
File "src/dbCache.ml", line 1:
Error: /usr/lib/ocaml/sqlite3/sqlite3.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.
==> CHYBA: Došlo k chybě v build().
Jenže Antergos je rolling distribuce takže když snížím verzi balíčku tak je obrovská šance že to celé rozbiju a dříve nebo později budu muset instalovat načisto. Co s tím? Má to řešení? Tedy kromě použití něčeho jiného :-)

Livan
Příspěvky: 134
Registrován: 16 kvě 2014, 21:15

Re: Google Drive

#10 Příspěvek od Livan » 30 lis 2018, 15:20

Abby píše:
30 lis 2018, 14:36
Jen se zeptám, v pamac (Přidat/odebrat software?) mám i google-drive-ocamlfuse-git, nestačilo by třeba nainstalovat tohle? Nebo se to musí přes ten příkaz v konsoli? A jak se to případně odinstaluje když by to nefungovalo?
Zkús teda nainštalovať tú verziu google-drive-ocamlfuse-git malo by to stačiť.

Odpovědět