Krusader 2.7.1

Diskuze, problémy a zkušenosti s programy, nástroji nebo balíčkovacími systémy
Zpráva
Autor
Livan
Příspěvky: 97
Registrován: 16 kvě 2014, 21:15

Re: Krusader 2.7.1

#11 Příspěvek od Livan » 08 bře 2019, 14:55

Ventero1 píše:
08 bře 2019, 10:15
Teď jsem si vzpoměl, proč usuzuji, že QT jsou modernější - protože Lubuntu tuším přechází nebo přešlo z LXDE na LXQT ...

Takže chaláni - jak to teda je ... - nooó ?!
Tak to je jednoduché. Byl jednou jeden programovací jazyk, kterému se říkalo C. Na jeho základě a pro jeho podporu vznikly grafické knihovny GTK a později GTK+. Později byl jazyk C doplněn o vlastnosti objektově orientovaného programování a tak vznikl programovací jazyk C++. A zase na jeho základě a pro jeho podporu vznikly grafické knihovny QT. Takže na základě napsaného je vidět, že QT je novější a teda i modernější.

Uživatelský avatar
redhawk
Guru Mintu
Příspěvky: 2700
Registrován: 12 led 2016, 19:14
Bydliště: ako kedy
Kontaktovat uživatele:

Re: Krusader 2.7.1

#12 Příspěvek od redhawk » 08 bře 2019, 15:05

Ventero1 píše:
07 bře 2019, 10:02
Myslel jsem, ze qt jsou modernejsi, nez gtk - takze je to naopak, kdyz LM prestava qt podporovat? Odchazi qt do propadliste dejin?
QT ma a bude mat svoju zakladnu rovnako ako GTK+
GTK pouziva Gnome, Cinnamon, Mate, XFCE,
QT = KDE, LXQT, Lumina, Trinity, Liri,
ale je este napr. FLT (Fast Light Toolkit) a na nom je tiez par de
Naposledy upravil(a) redhawk dne 08 bře 2019, 15:06, celkem upraveno 1 x.
Pravděpodobně kecám.

Uživatelský avatar
redhawk
Guru Mintu
Příspěvky: 2700
Registrován: 12 led 2016, 19:14
Bydliště: ako kedy
Kontaktovat uživatele:

Re: Krusader 2.7.1

#13 Příspěvek od redhawk » 08 bře 2019, 15:06

Livan píše:
08 bře 2019, 14:55
Ventero1 píše:
08 bře 2019, 10:15
Teď jsem si vzpoměl, proč usuzuji, že QT jsou modernější - protože Lubuntu tuším přechází nebo přešlo z LXDE na LXQT ...

Takže chaláni - jak to teda je ... - nooó ?!
Tak to je jednoduché. Byl jednou jeden programovací jazyk, kterému se říkalo C. Na jeho základě a pro jeho podporu vznikly grafické knihovny GTK a později GTK+. Později byl jazyk C doplněn o vlastnosti objektově orientovaného programování a tak vznikl programovací jazyk C++. A zase na jeho základě a pro jeho podporu vznikly grafické knihovny QT. Takže na základě napsaného je vidět, že QT je novější a teda i modernější.
no GTK3 pouziva tiez C++
Pravděpodobně kecám.

Uživatelský avatar
Ventero1
Vezír Mintu
Příspěvky: 644
Registrován: 31 říj 2016, 14:17
Bydliště: Sokolov

Re: Krusader 2.7.1

#14 Příspěvek od Ventero1 » 08 bře 2019, 15:49

Myslim, ze jsem u sebe v Xubu taky videl nekde nejake qt - je to mozne nebo tto patrilo k nejakemu programu, aby fungoval na vice prostredi?
Zvuky jsou mantrami a myšlenky moudrostí, prostě proto, že se mohou objevovat ...

takyradejianonymne
Příspěvky: 22
Registrován: 30 črc 2018, 13:39

Re: Krusader 2.7.1

#15 Příspěvek od takyradejianonymne » 08 bře 2019, 20:05

Používat tady pojem modernější je nesmysl a když ta dvojice KDE a GNOME to spolu táhnou vedle sebe asi už od pravěku, proč LXDE přešlo v dalším stupni na LXQt je protože projekt se sloučil s Razor-qt a současně v jistý okamžik panovala s GTK3 nespokojenost a viz
https://cs.wikipedia.org/wiki/LXQt
proto ve slušnější distribuci a která na to má jsou udržovány na úrovni jak knihovny Qt tak GTKx a Mint tím pádem slušnou distribucí přestal být, jako by mu docházel dech tedy také prašule a nebo alespoň filantropie dárců a i ta od vývojářů, dle mne místo 3 v podstatě dnes stejných desktopů postavených na GTK3 měl Mint provést jejich redukci (třeba buď Mate nebo Cinnamon) a naopak aby to KDE zůstalo a v nějak slušné vždy aktuální úrovni protože si to zaslouží. Dle mne, pokud na to hardware má a není to opravdu stará vykopávka, tak dnes já upřednostním to KDE5 před Xfce. Xfce si chválím a byl jsem spokojený, ale zjevně i tam chybí kapacity aby to dalo nějaké záruky i do budoucna a jako že bude rychlé přizpůsobení tomu co se v Linuxu chystá.

Odpovědět