PAC manager

Diskuze, problémy a zkušenosti s programy, nástroji nebo balíčkovacími systémy
Odpovědět
Zpráva
Autor
tomato
Příspěvky: 2
Registrován: 23 říj 2020, 09:24

PAC manager

#1 Příspěvek od tomato » 23 říj 2020, 09:29

Hoj,

porteboval bych rozbehat nejaky ssh manager, nasel jsem PAC manager ze by mohl vyhovovat (https://sourceforge.net/projects/pacmanager/), ale nedari se mi nainstalovat.
Mint 20, 5.4.0-52-generic #57-Ubuntu

Kód: Vybrat vše

tomato@freak:~/Downloads$ sudo dpkg -i pac-4.5.5.7-all.deb
Selecting previously unselected package pac.
(Reading database ... 397355 files and directories currently installed.)
Preparing to unpack pac-4.5.5.7-all.deb ...
Unpacking pac (4.5.5.7) ...
dpkg: dependency problems prevent configuration of pac:
 pac depends on libvte9; however:
  Package libvte9 is not installed.
 pac depends on libgnome2-gconf-perl; however:
  Package libgnome2-gconf-perl is not installed.
 pac depends on libexpect-perl; however:
  Package libexpect-perl is not installed.
 pac depends on libnet-proxy-perl; however:
  Package libnet-proxy-perl is not installed.
 pac depends on libyaml-perl; however:
  Package libyaml-perl is not installed.
 pac depends on libcrypt-cbc-perl; however:
  Package libcrypt-cbc-perl is not installed.
 pac depends on libcrypt-blowfish-perl; however:
  Package libcrypt-blowfish-perl is not installed.
 pac depends on libgtk2-gladexml-perl; however:
  Package libgtk2-gladexml-perl is not installed.
 pac depends on libgtk2-ex-simple-list-perl; however:
  Package libgtk2-ex-simple-list-perl is not installed.
 pac depends on libnet-arp-perl; however:
  Package libnet-arp-perl is not installed.
 pac depends on libossp-uuid-perl; however:
  Package libossp-uuid-perl is not installed.
 pac depends on libcrypt-rijndael-perl; however:
  Package libcrypt-rijndael-perl is not installed.
 pac depends on libgtk2-unique-perl; however:
  Package libgtk2-unique-perl is not installed.

dpkg: error processing package pac (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24+linuxmint1) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Errors were encountered while processing:
 pac
tomato@freak:~/Downloads$ 
existuje nejaky repository ktery muzu pridat abych splnil zavislosti?
fix mi akorat chce pac odinstalovat:

Kód: Vybrat vše

tomato@freak:~/Downloads$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  pac
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 5 120 kB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.
tomato@freak:~/Downloads$ 
predem dik,
Honza

juhele2014
Guru Mintu
Příspěvky: 2376
Registrován: 19 kvě 2014, 17:47

Re: PAC manager

#2 Příspěvek od juhele2014 » 23 říj 2020, 19:18

Tak bohužel ... Zkoušel jsem LM 19.3, LM 20, a ani v LM 19.2 xfce to nejede. Nainstaluji, ale nespustím, píše to:

Kód: Vybrat vše

rudla@rudla-pc:~$ pac
PAC started (pac) with PID 5943
ERROR: PAC was unable to load *any* config file from '/home/rudla/.config/pac'... Now starting from scratch...Use of uninitialized value in string eq at /opt/pac/lib/PACConfig.pm line 672.
Segmentation fault (core dumped)
rudla@rudla-pc:~$ sh: 1: kill: No such process
Mimochodem, na řádku 672 je tohle if ( $$self{_CFG}{'tmp'}{'tray available'} eq 'warning' ) {
--------------------------------------------
edit:
Tak nyní jsem to rozjel na tomto systému:

Kód: Vybrat vše

System:    Host: kafemlejnek Kernel: 4.15.18-041518-generic x86_64 (64 bit)
           Desktop: Cinnamon 2.8.8  Distro: Linux Mint 17.3 Rosa
Po prvním spuštění to hodí informační okénko
pict1.jpg
, ale pak to normálně funguje. Aspoň se to tak tváří ... :roll:

tomato
Příspěvky: 2
Registrován: 23 říj 2020, 09:24

Re: PAC manager

#3 Příspěvek od tomato » 26 říj 2020, 11:13

ok, kazdopadne dik, zkusim nejakou alternativu..

Odpovědět