Která nejvyšší verze Wine je t.č. stabilní?

Zde řešíme problémy se softwarem, určeným pro Windows a spustitelným pres nástroj Wine i v Linux Mintu
Odpovědět
Zpráva
Autor
hank
Příspěvky: 87
Registrován: 10 lis 2015, 16:56

Která nejvyšší verze Wine je t.č. stabilní?

#1 Příspěvek od hank » 13 říj 2018, 22:20

Omlouvám se za hloupej dotaz, ale v repozitářích je pořád Wine 1.6.2... Na notebooku vyhrazeném pro všelijaké experimentování a jiné bastlení mám pod LM 18.3 (zatím v pohodě) 3.15 deklarovanou jako nestabilní, na různých linuxovských fórech jsem jako nejvyšší stabilní (k různým datům v květnu - srpnu t.r.) našel doporučené verze 3.0 až 3.0.3. Můžete prosím poradit?

A ještě: PlayOnLinux mám 4.2.10. Bude s Wine 3.0.x fungovat dobře?

kamowski
Vezír Mintu
Příspěvky: 957
Registrován: 01 pro 2012, 16:30
Kontaktovat uživatele:

Re: Která nejvyšší verze Wine je t.č. stabilní?

#2 Příspěvek od kamowski » 14 říj 2018, 10:35

no ak ten nb máš vyhradený
hank píše:
13 říj 2018, 22:20
... pro všelijaké experimentování a jiné bastlení ...
tak to vyskúšaj a napíš ty nám, či je to funkčné?, či sú tam nejaké chyby?, ako sa prejavujú?, ako si to skúsil opraviť a s akým výsledkom? ...
toto nie je žiadna provokácia, myslím to vážne

hank
Příspěvky: 87
Registrován: 10 lis 2015, 16:56

Re: Která nejvyšší verze Wine je t.č. stabilní?

#3 Příspěvek od hank » 14 říj 2018, 11:34

kamowski: Já nemám předpoklady dělat testera, já jsem jenom mírně poučený BFU a spíš náhodně zkouším věci, které zrovna potřebuju. Ani nemám ponětí o správné metodice takového testování a používaných nástrojích. Nějaké dílčí poznatky, které by IMHO mohly být pro toto fórum užitečné, sem občas dávám, ale na systematičtější práci fakt nemám čas ani znalosti.

Teď jsem řešil Anyrail 6.17.4., který mi pod předpotopním repozitářovým Wine 1.6.2. neběžel korektně (= rozházené grafické rozhraní), tak jsem hledal náhradu. Nejdřív jsem narazil na CrossOver, ale ten je placený; v čínském distru Deepin měl být sice zadarmo, jenže jejich repozitáře byly zrovna v ten moment nepřístupné a když jsem se do toho "obchodu" (Appstore Deepin) zase dostal, CrossOver jsem tam stejně nenašel. Pak jsem ten Anyrail zkusil pod údajně zatím nestabilním Wine 3.15 a tam mi to běželo správně. (Deepin jsem zase hned odinstaloval, to "polished" prostředí, které někdo někde nazval omalovánkami, se mi vůbec nelíbí.) Takže jsem začal zjišťovat, který Wine 3.0.x je stabilní, a protože mně dostupné informace se rozcházejí, tak jsem se tady zeptal, abych si to zkoušení ušetřil. Jestli tu odpověď nedostanu, no tak to asi budu muset zkusít sám; otázka ovšem je, jestli to, co jede na jednom počítači, mi ten druhý nezbourá, protože na něm pracuju a bylo by to mrzuté. Proto se pokouším zjistit, jak jsou na tom jiní.

zeleno110
Příspěvky: 48
Registrován: 08 lis 2017, 17:12

Re: Která nejvyšší verze Wine je t.č. stabilní?

#4 Příspěvek od zeleno110 » 14 říj 2018, 12:48

Stabilné Wine v tom zmysle, že tam pôjdu všetky programy, to asi nenájdeš. Jeden program pôjde lepšie na 1.6.2 a iný na 3.18.
Nato je v Playonlinuxe tá možnosť, že si stiahneš a vyskúšaš akékoľvek verzie wine a doinštaluješ niektoré win knižnice. Čiastočne sa dá
pomôcť si prehľadom skúseností na winehq napríklad https://appdb.winehq.org/objectManager. ... &iId=31385
ak tam však svoju verziu nenájdeš, tak je skúšanie na tebe.
To, či ti to pôjde na inom počítači je viacmenej otázka ovladačov grafickej karty, ak je tam iný typ grafickej karty, môže sa to správať rozdielne, ale počítač by to pokaziť nemalo. Neviem, aké programy chceš ešte inštalovať, tak sa radšej predtým informuj.
Za 10 rokov som cez wine skúšobne naištaloval vyše 300 rôznych windows programov a ich verzii a nič sa počítačom nestalo, až na pár zamrznutí a nutnosti tvrdého reštartu.

hank
Příspěvky: 87
Registrován: 10 lis 2015, 16:56

Re: Která nejvyšší verze Wine je t.č. stabilní?

#5 Příspěvek od hank » 14 říj 2018, 13:40

zeleno110 píše:
14 říj 2018, 12:48
Stabilné Wine v tom zmysle, že tam pôjdu všetky programy, to asi nenájdeš. Jeden program pôjde lepšie na 1.6.2 a iný na 3.18.
Nato je v Playonlinuxe tá možnosť, že si stiahneš a vyskúšaš akékoľvek verzie wine a doinštaluješ niektoré win knižnice. Čiastočne sa dá
pomôcť si prehľadom skúseností na winehq napríklad https://appdb.winehq.org/objectManager. ... &iId=31385
ak tam však svoju verziu nenájdeš, tak je skúšanie na tebe.
To, či ti to pôjde na inom počítači je viacmenej otázka ovladačov grafickej karty, ak je tam iný typ grafickej karty, môže sa to správať rozdielne, ale počítač by to pokaziť nemalo. Neviem, aké programy chceš ešte inštalovať, tak sa radšej predtým informuj.
Za 10 rokov som cez wine skúšobne naištaloval vyše 300 rôznych windows programov a ich verzii a nič sa počítačom nestalo, až na pár zamrznutí a nutnosti tvrdého reštartu.
Děkuji. Na obou dotčených PC mám grafiku nVidia, ovladače si pravidelně aktualizuji, tak tam mám stále poslední verze (myslím, že teď to je 396).

Takže když pro začátek nainstaluju třeba Wine 3.0.3 - PlayOnLinux je 4.2.10 - žádnou katastrofu čekat nemusím? A když bych s tím chtěl zkusit Corel Photo-Paint X6, které windows knihovny bys mi k tomu poradil? (I když na WineHQ je všechno od X4 nahoru označeno jako garbage; já vím, že GIMP atd., ale mám tu ještě z wokenních dob pár starých souborů v nativním formátu .cpt a teď jsem zrovna zjistil, že některé potřebuju... Když bude nejhůř, tak to bude jistit Virtualbox :roll: )

zeleno110
Příspěvky: 48
Registrován: 08 lis 2017, 17:12

Re: Která nejvyšší verze Wine je t.č. stabilní?

#6 Příspěvek od zeleno110 » 14 říj 2018, 17:15

X6-ku vo wine nerozchodíš, zatial by si mohol nainštalovať trial Corel AfterShot Pro pre linux https://www.aftershotpro.com/en/free-tr ... t-pro.html ten by mal vedieť otvoriť .cpt obrázky a uložiť ich v inom použitelnejšom formáte. Tiež sa dá použiť Inkscape a XnView.

hank
Příspěvky: 87
Registrován: 10 lis 2015, 16:56

Re: Která nejvyšší verze Wine je t.č. stabilní?

#7 Příspěvek od hank » 14 říj 2018, 19:14

zeleno110 píše:
14 říj 2018, 17:15
X6-ku vo wine nerozchodíš
To už jsem mezitím zjistil taky, mám ji v 64b verzi, která si při instalaci vyžádala knihovny k DotNet 4.0, jenže ty se mi nabídly jen 32b... :( Takže VirtualBox.

zeleno110 píše:
14 říj 2018, 17:15
Tiež sa dá použiť Inkscape a XnView.
Jako že ty dva umějí otevřít formát .cpt a uložit ho do něčeho rozumnějšího?

Jinak ale mě Wine+Playonlinux docela překvapily, zkusil jsem z jejich nabídky nainstalovat MS Paint a on si ten emulátor sám řekl o instalaci jiné verze Wine a Gecko, pod kterou to poběží...

Uživatelský avatar
redhawk
Guru Mintu
Příspěvky: 2255
Registrován: 12 led 2016, 19:14
Kontaktovat uživatele:

Re: Která nejvyšší verze Wine je t.č. stabilní?

#8 Příspěvek od redhawk » 14 říj 2018, 19:25

hank píše:
14 říj 2018, 19:14

Jinak ale mě Wine+Playonlinux docela překvapily, zkusil jsem z jejich nabídky nainstalovat MS Paint a on si ten emulátor sám řekl o instalaci jiné verze Wine a Gecko, pod kterou to poběží...
na to je playonlinux urceny, taktiez si vie manazovat 32 a 64bit verzie.
osobne som sa naucil ale pouzivat programy pod linux. Zistil som ze zvyk z windows k programom je zvyk, ku kazdemu existuje free alternativa.

BTW ten corel aftershot pro je nativny corelacky sw, mal by to vediet urobit z cpt do nejakeho psd alebo svg pre gimp

EDIT: tak podla nirsoftu cpt (corel presentation)
otvori: Corel PhotoPaint, IrfanView, XnViewMP, GIMP, PDF creator,
Smrt nikdy nelže

hank
Příspěvky: 87
Registrován: 10 lis 2015, 16:56

Re: Která nejvyšší verze Wine je t.č. stabilní?

#9 Příspěvek od hank » 14 říj 2018, 21:24

Děkuji všem za užitečné informace.

Odpovědět